Corrupt EFI 820-3476 EMC2875

imac-Repairs

Active Member
VIP MEMBER
Feb 5, 2018
29
0
53
Hi,

I have a MacBook Pro 13" 2014 EMC 2875 which just chimes and then restarts. I've tried about 6/7 different EFI's but not able to make it work properly. The closest i have go to is for it to start but it gets stuck on the Apple logo.

Can someone fix the attached EFI please.

Thanks
 

Attachments

  • original.bin
    8 MB · Views: 16

ThienBui

CEO
Supporter
Dec 13, 2013
92,101
1
6,317
VinaFix
vinafix.com
imac-Repairs said:
Hi,

I have a MacBook Pro 13" 2014 EMC 2875 which just chimes and then restarts. I've tried about 6/7 different EFI's but not able to make it work properly. The closest i have go to is for it to start but it gets stuck on the Apple logo.

Can someone fix the attached EFI please.

Thanks
Hang logo ?
 

Attachments

  • Clear me 820-3476.bin.zip
    4.3 MB · Views: 33

imac-Repairs

Active Member
VIP MEMBER
Feb 5, 2018
29
0
53
The original bin file when the eDP is connected it chimes restarts, chime restarts continuously. Without eDP chimes ok but of course no display.

I have tried another EFI file (working but hangs.bin) and it boots ok with eDP connected but logo hangs.
 

Attachments

  • original.bin
    8 MB · Views: 9
  • working but hangs.bin
    8 MB · Views: 16

imac-Repairs

Active Member
VIP MEMBER
Feb 5, 2018
29
0
53
From pressing power button long time for chime and then hangs on Apple logo. Never see main screen.
 

Attachments

  • 15301398220292170160467548382736.jpg
    15301398220292170160467548382736.jpg
    862.9 KB · Views: 2